找回密码
 加入网盟
分割线
官方精品推荐


方法1:
  1. .版本 2
  2. .支持库 internet
  3. .子程序 取外网ip_文本操作, 文本型
  4. .局部变量 内容, 文本型
  5. .局部变量 开始位置, 整数型
  6. .局部变量 长度, 整数型
  7. .局部变量 网址, 文本型
  8. .局部变量 开始标识符, 文本型
  9. .局部变量 结束标识符, 文本型
  10. 网址 = “http://www.net.cn/static/customercare/yourIP.asp”
  11. 开始标识符 = “<h2>”
  12. 结束标识符 = “</h2>”
  13. 内容 = 到文本 (HTTP读文件 (网址))
  14. 开始位置 = 寻找文本 (内容, 开始标识符, , 假) + 取文本长度 (开始标识符)
  15. 长度 = 取文本长度 (内容) - 取文本长度 (开始标识符) - 寻找文本 (内容, 开始标识符, , 假) - (取文本长度 (内容) - 寻找文本 (内容, 结束标识符, , 假))
  16. 返回 (取文本中间 (内容, 开始位置, 长度))
复制代码
方法2:
  1. .版本 2
  2. .支持库 RegEx
  3. .支持库 internet
  4. .子程序 取外网ip_正则操作, 文本型
  5. .局部变量 开始标识符, 文本型
  6. .局部变量 结束标识符, 文本型
  7. .局部变量 正则, 正则表达式
  8. .局部变量 结果, 搜索结果
  9. .局部变量 内容, 文本型
  10. .局部变量 网址, 文本型
  11. 开始标识符 = “<h2>”
  12. 结束标识符 = “</h2>”
  13. 网址 = “http://www.net.cn/static/customercare/yourIP.asp”
  14. 正则.创建 (开始标识符 + “(.*?)” + 结束标识符, 假)
  15. 内容 = 到文本 (HTTP读文件 (网址))
  16. 结果 = 正则.搜索 (内容, 1, )
  17. 返回 (结果.取子匹配文本 (内容, 1, ))
复制代码


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?加入网盟

x
分享至 : QQ空间
收藏

1 个回复

倒序浏览
感谢{author}楼主
回复 使用道具 举报
您需要登录后才可以回帖 登录 | 加入网盟
关闭

华夏网盟推荐 上一条 /1 下一条