找回密码
 加入网盟
分割线
官方精品推荐
有时候我们需要用到目录遍历这个功能,比如说找出一个文件夹及子文件夹下面所有空文件夹并删除,这时候就要用到易语言目录遍历了。网上搜到的都是一些递归调用子程序的解决方法,好复杂,我等菜鸟直接用不上,PASS,下面看个简单的。

使用工具
易语言软件
精易模块
1.自己新建几个文件夹试试呗。
直接贴出代码:

  1. .版本 2

  2. .支持库 spec

  3. .子程序 _按钮2_被单击

  4. .局部变量 数组, 文本型, , "0"

  5. 目录_枚举子目录1 (“F:\新建文件夹”, 数组, 真, 真)

  6. 调试输出 (数组)
复制代码




2.注意:这里我们是用的模块里面的“目录_枚举子目录1()” 而不是“目录_枚举子目录()”,目录_枚举子目录()这个只能遍历一级目录,子目录遍历不出来!
3.看看效果:已经可以遍历文件夹及子文件夹了,是不是很简单



注意事项
实现遍历目录及子目录需要用到模块的“目录_枚举子目录1()”命令!不是“目录_枚举子目录()!”

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?加入网盟

x
分享至 : QQ空间
收藏

2 个回复

倒序浏览
davidchen34484 1 2022-9-23 22:14:03
2#
{author} 感谢楼主分享
回复 使用道具 举报
thanhlong611 1 2022-9-24 00:00:24
3#
非常感谢
回复 使用道具 举报
您需要登录后才可以回帖 登录 | 加入网盟
关闭

华夏网盟推荐 上一条 /1 下一条